r-pod Nation Homepage R-Pod Travel Trailers At Jeff Couchs RV Nation
Forum Home Forum Home > Forest River r-pod > Maintenance Issues, Tips and Tricks
  New Posts New Posts RSS Feed - Leaking AC
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Leaking AC

 Post Reply Post Reply Page  <12
Author
Message
Oliver View Drop Down
Senior Member
Senior Member


Joined: 23 Mar 2018
Status: Offline
Points: 184
Post Options Post Options   Thanks (0) Thanks(0)   Quote Oliver Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jun 2019 at 7:07pm
Looks like they skimped the back. There are two bolts in the front. There are two holes where bolts could be in the rear, but there is only one hole between them with a bolt. Anyway I've tightened them and put the cover back on. Time will tell I guess, but that back bolt was wet so I suspect that was the culprit. When I tightened it, it dryed up.
Back to Top
Oliver View Drop Down
Senior Member
Senior Member


Joined: 23 Mar 2018
Status: Offline
Points: 184
Post Options Post Options   Thanks (0) Thanks(0)   Quote Oliver Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jun 2019 at 9:26pm
Started leaking again. Took the cover back off. Tightened some more.
Back to Top
Oliver View Drop Down
Senior Member
Senior Member


Joined: 23 Mar 2018
Status: Offline
Points: 184
Post Options Post Options   Thanks (0) Thanks(0)   Quote Oliver Quote  Post ReplyReply Direct Link To This Post Posted: 23 Jun 2019 at 8:54pm
I tightened a little more until it stopped leaking. It is dry so far. Maybe that did it. A friend asked me if those 3 bolts were all that are keeping the AC on the roof?
Back to Top
Oliver View Drop Down
Senior Member
Senior Member


Joined: 23 Mar 2018
Status: Offline
Points: 184
Post Options Post Options   Thanks (0) Thanks(0)   Quote Oliver Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jun 2019 at 3:17pm
I'm thinking it must be condensation. Because it only leaks with the cover on. Then just a couple drops or less, and when it's either rainy or high humidity. Or both. When I take the cover off...no moisture!
Back to Top
mcarter View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 Apr 2017
Location: Greenbrier, TN
Status: Offline
Points: 131
Post Options Post Options   Thanks (0) Thanks(0)   Quote mcarter Quote  Post ReplyReply Direct Link To This Post Posted: 27 Jun 2019 at 5:44pm
Are the filters clean?
Mike Carter
2015 178
Back to Top
Oliver View Drop Down
Senior Member
Senior Member


Joined: 23 Mar 2018
Status: Offline
Points: 184
Post Options Post Options   Thanks (0) Thanks(0)   Quote Oliver Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jun 2019 at 5:05pm
Yes the filters are clean. The cover has been off for a couple days and no moisture. It only happens when I put the cover back on. there is a slide on it and I think when that's closed it creates condensation. I could be wrong, but there are 3 bolts. I have tightened them and I don't wor't to overdo that. Somebody suggested inserting a small hose on the outside where it leaks and let the water run off the side instead of the rear and mar the finish. Do you know if it leaks water just in that hole on one side? Maybe all that water is not running off the roof and is backing up. But what do I know...
Back to Top
mcarter View Drop Down
Senior Member
Senior Member
Avatar

Joined: 12 Apr 2017
Location: Greenbrier, TN
Status: Offline
Points: 131
Post Options Post Options   Thanks (0) Thanks(0)   Quote mcarter Quote  Post ReplyReply Direct Link To This Post Posted: 28 Jun 2019 at 5:48pm
Mine drains , same place always when trailer is level.  Front left almost directly over the accessory/convenience light on the front.
Mike Carter
2015 178
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.0
Copyright ©2001-2014 Web Wiz Ltd.